patchwork

an assorted collection of randomness and non-essential remarks
Have at least one original repos where PHP is the dominant language The walrus is no stranger to variety. Use at least 4 different languages throughout all your repos Fork and commit to someone's open source project in need Have a project valued enough to be forked by someone else Have at least three original repos where Ruby is the dominant language Have at least one original repo where Ruby is the dominant language Have at least one original repo where some form of shell script is the dominant language
Endorse tarakanbg on Coderwall Powered by Obtvse

Gems updated for Ruby 2.0 - Part 1

In the wake of the recent Ruby 2.0 release over the last few days I've updated some of my gems for 2.0 compatibility.

This batch includes all of my aviation & vatsim related libraries, except for airdata, which as a rails engine will be updated/tested for compatibility with the Rails 4 / Ruby 2 combo when its time comes.

This being a maintenance release, some minor refactoring changes and dependency updates were also implemented where applicable.

The list of updated gems:

All listed gems still support the Ruby 1.9.3 + versions, however the support for the 1.8.x branch has been dropped with this latest update.

Back to Blog